Compiling Issue

Started by TeckHock, November 25, 2023, 01:31:58 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

TeckHock

I have managed to install QT and MinGW and able to open \fet-6.13.0\src\src.pro
I can run FET via QT.
Pls see picture 1.

However, when I double click the FET.exe, I got this error. Pls see picture 2.

Any1 can help?

Thks

Liviu Lalescu

Hello,

1) It is not a good idea to create double users for the same person.

2) Please note that FET is completely free, depending completely on user support. It would be great if you could become a supporter. If you are interested into a contract work, I could also dedicate more time to your problem.

3) I would recommend you to update to FET-6.13.1, which solves some possible nasty crash bugs from 6.12.0 and 6.13.0. I apologize.

4) If you run Windows 11, I recommend the latest Qt 6.6.0, and Qt Creator 11 or 12.

5) Be careful: it seems you compiled FET in debug mode - in which case it will run much slower. You need to run it in release mode.

6) You will need to copy the dll-s of MinGW and Qt near the fet.exe file, in the same way I do with the official FET package.

7) I usually compile from the command-line, with setting the path to Qt bin and to MinGW bin. I am not sure where you can set the 'release' target if you compile from Qt Creator.

TeckHock

Thanks for the prompt reply.

Sorry I created another account because I lost the password of the first account.
The password reset only came in this morning. Apology.

Will stop using this new account and stick to the first account.

Will try as per advice by u.

Thks again

Teck Hock

When I use the unified installer, qt-unified-windows-x64-4.6.1-online.exe,
I hit the attached error.
Can help?
Thks

Volker Dirr

This is an Qt error. You should ask in the Qt forum:
https://forum.qt.io/

I can see that you try to download the android version. I tried that the last time some years ago and it didn't work. But since some years past now, it might work. Let me know if you can run FET on android. Even i don't see a good reason for running FET on android, since the screen size of android devices (phones) are normally much too small for a tool like FET and also the cell is much too small to run it for a longer time on full load. But maybe you try to use an android TV? But i fear those CPUs are not optimized for fast computing, they are normally optimized for fast encoding videos, but that is mostly done by the GPU, not the CPU.

Liviu Lalescu

#5
Sorry, no problem!

You must select Qt 6.6.0 for MinGW 11.2.0-64bit, and install also from tools MinGW 11.2.0.

Teck Hock

Managed to get it installed but is QT 6.6.1.

When I compile, I got this attached error.

Can help?

Thks

Liviu Lalescu

If I am on Windows 10 64bit, I install Qt 6.6.1 for MinGW 11.2.0 64bit, and in Tools I also install MinGW 11.2.0 64bit.

Then I unpack the FET tar.bz2 archive with a good unpacker (I use two phases, in the first phase I open with 7-zip and obtain a tar file, then I unpack with Total Commander).

Then I go to command line (cmd) and write:

set PATH=C:\Qt\6.6.1\mingw_64\bin;C:\Qt\Tools\mingw1120_64\bin;%PATH%
qmake (or qmake fet.pro)
mingw32-make -j 16 (I have 8 core / 16 threads computer).

After this, which takes ~12 minutes, you should be able to open the project with Qt Creator. I don't know exactly how to open the project and configure it with Qt Creator before doing the compilation from the command line.

Teck Hock

Hi

I have followed your instructions:

1. I install Qt 6.6.1 for MinGW 11.2.0 64bit, and in Tools I also install MinGW 11.2.0 64bit.
2. set PATH=D:\Qt\6.6.1\mingw_64\bin;D:\Qt\Tools\mingw1120_64\bin;%PATH%
3. qmake (or qmake fet.pro)
4. mingw32-make -j 16

I still have the same error during Step 4 that I open using QT.

Any advise?

Thks

Liviu Lalescu

#9
a) Please update to FET 6.14.1 (latest), because fixes some important bugs.

b) Not necessarily -j 16, but -j x, where x is your recommended running threads. What processor do you have? How many cores/threads?

c) Run cmd from fet-6.14.1, not from fet-6.14.1/src (this is the error). As I told you an alternative, qmake fet.pro; fet.pro is found in fet-6.14.1.

d) After (hopefully) the successful compilation, you will need to copy the dlls like I do in the official FET Windows 10 64bit archive (get 3 dlls from MinGW, 5 from Qt, and other 3 directories (leave only one dll in each) again from Qt. You can additionally also update the licenses directory, like I do.

Teck Hock

How do I check the core and thread?

Thks

Liviu Lalescu


Teck Hock

Thks for all the help.
I have managed to install QT, view the UI and compile FET.

Liviu Lalescu

After the successful compilation, you should be able to open fet.pro with Qt Creator.

I would like to refer you again to the point 2) in my post #1: FET is completely free software, depending on kind donations, so it would be great if you or your institution could recommend such a financial help.