Author Topic: Compiling problem in kubuntu 16.04 with Qt 5.7 and fet 5.30.2  (Read 470 times)

0 Members and 1 Guest are viewing this topic.

auriolar

  • Level 1
  • *
  • Posts: 12
    • View Profile
Compiling problem in kubuntu 16.04 with Qt 5.7 and fet 5.30.2
« on: August 03, 2016, 02:32:31 AM »
Hello,
I don't know if it's a bug or if it's my setup but I've been trying to compile the lastest fet but I get this message:
Code: [Select]
make[1]: *** No rule to make target 'interface/modifyconstraintactivitiesmaxsimultaneousinselectedtimeslotsform_template.ui', needed by '../tmp/gui/ui_modifyconstraintactivitiesmaxsimultaneousinselectedtimeslotsform_template.h'.  Stop.
make[1]: Leaving directory '/home/asier/Hezkuntza/fet/fet-5.30.2/src'
Makefile:43: recipe for target 'sub-src-src-pro-make_first' failed

How can I solve it?

Thanks!

Liviu Lalescu

  • Forum Administrator
  • Level 5
  • *****
  • Posts: 5180
  • FET author and forum moderator
    • View Profile
    • Homepage
Re: Compiling problem in kubuntu 16.04 with Qt 5.7 and fet 5.30.2
« Reply #1 on: August 03, 2016, 02:36:34 AM »
I think you unpacked incorrectly the archive and the file name (which is very long) gets truncated. Please do: tar -jxvf fet-5.30.2.tar.bz2.

auriolar

  • Level 1
  • *
  • Posts: 12
    • View Profile
Re: Compiling problem in kubuntu 16.04 with Qt 5.7 and fet 5.30.2
« Reply #2 on: August 03, 2016, 01:29:41 PM »
That was it!   :-[
Thank you

Liviu Lalescu

  • Forum Administrator
  • Level 5
  • *****
  • Posts: 5180
  • FET author and forum moderator
    • View Profile
    • Homepage
Re: Compiling problem in kubuntu 16.04 with Qt 5.7 and fet 5.30.2
« Reply #3 on: August 03, 2016, 01:33:03 PM »
What unpacker did you use initially?

az1408

  • Level 1
  • *
  • Posts: 1
    • View Profile
Re: Compiling problem in kubuntu 16.04 with Qt 5.7 and fet 5.30.2
« Reply #4 on: December 20, 2016, 03:36:27 PM »
 I have the same error when i try to run it on windows with QT ...WHAT SHOULD I DO ?

Failure to find: interface\modifyconstraintactivitiesmaxsimultaneousinselectedtimeslotsform_template.ui

Volker Dirr

  • Forum Administrator
  • Level 5
  • *****
  • Posts: 1906
    • View Profile
Re: Compiling problem in kubuntu 16.04 with Qt 5.7 and fet 5.30.2
« Reply #5 on: December 20, 2016, 06:01:06 PM »
the problem is that several "new" unzip tools use a pretty old decomcompression source/algorithm.
please use a newer one.
please read following links to get more information:
Please read:
http://lalescu.ro/liviu/fet/forum/index.php?topic=1404.0
and
http://lalescu.ro/liviu/fet/forum/index.php?topic=1884.0