FET 10.2 problem during execution

Started by necati sekkeli, August 22, 2009, 04:20:39 PM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

necati sekkeli

I am using mingw and QT 4.3.2 with gcc for compiling FET with my Windows XP.

I added a simple function to take hardware info of the PC. Also the code compiles. However, the .exe file crashes during the beginning of the execution. It reports that problem is about QtCore4.dll file.

I tried different versions (4.3.2, 4.3.3) of same dll but its same. Can you give me a hint? Does anyone have an idea? I think the problem is about an conflict between GetSystemInfo method and this DLL.

my code is like that:

#include <Windows.h>
....
char* LockUnlock::lookforpcvalues()
{
  SYSTEM_INFO siSysInfo;

  // Copy the hardware information to the SYSTEM_INFO structure.
  GetSystemInfo(&siSysInfo);

  // Display the contents of the SYSTEM_INFO structure.
  char * result=  reinterpret_cast<char*>(siSysInfo.wProcessorRevision);

     return result;
}


Volker Dirr

Did you also tried the latest QT version?

Sorry, i can't see the bug at the moment.

Liviu Lalescu

#2
I have no idea :-[.

Maybe you could also ask on the Qt site, they might know. See qtsoftware.com. They have a multitude of forums or mailing lists.