Problem compiling fet 5.34

Started by Davide Cottignoli, November 13, 2017, 12:41:08 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Davide Cottignoli

I tried o compile the last source 5.34.0 on linux Mint 18.1 Serena and  I run into the following problems:
1) after few seconds the compilation stops with error like fatal error: GL/gl.h: No such file or directory; as you reported in readme file I was able to solve by installing the "mesa-common-dev" package.
2) after 15min of compilation time, the compiler run into the following error:

g++ -Wl,-O1 -Wl,-rpath,/opt/Qt5.9.2/5.9.2/gcc_64/lib -o ../fet ../tmp/gui/timetableexport.o ../tmp/gui/activity.o ../tmp/gui/solution.o ../tmp/gui/timetable.o ../tmp/gui/rules.o ../tmp/gui/import.o   [....many included file here... snip....]   ../tmp/gui/moc_modifyconstraintstudentsminrestinghoursform.o   -L/opt/Qt5.9.2/5.9.2/gcc_64/lib -lQt5PrintSupport -lQt5Widgets -lQt5Gui -lQt5Network -lQt5Core -lGL -lpthread
/usr/bin/ld: impossibile trovare -lGL
collect2: error: ld returned 1 exit status
Makefile:2613: set di istruzioni per l'obiettivo "../fet" non riuscito
make[1]: *** [../fet] Errore 1
make[1]: uscita dalla directory "/home/davide/sorgenti/fet-5.34.0/src"
Makefile:45: set di istruzioni per l'obiettivo "sub-src-src-pro-make_first" non riuscito
make: *** [sub-src-src-pro-make_first] Errore 2
davide@mint64 ~/sorgenti/fet-5.34.0 $

what package should be installed to go on?


Davide Cottignoli

I resolved myself: I had to install  the "libgl1-mesa-dev" package.


Liviu Lalescu

Thanks for the information! I added it in the README (for GNU/Linux Mint).